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Pre-Migration Preparation
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Pre-Migration Preparation

The following steps are recommended prior to starting a FileMaker Pro to SQL database migration 

project with FmPro Migrator.

FileMaker Pro 2,3,4 - File Preparation

There is no ODBC driver for FileMaker Pro 2,3,4 files, and the ODBC driver is required for 

transferring data from FileMaker Pro into other databases.

These older FileMaker Pro database files should be upgraded to FileMaker Pro 6 prior to 

performing the migration. 

The software download page for the licensed version of FmPro Migrator includes a FREE 

download link for FileMaker Pro 6 in order to upgrade older files.

1) Select the Help -> Check for Updates... menu item within FmPro Migrator.

The FmPro Migrator licensed software download page will be displayed in your web browser.

2) Download and install the FileMaker Pro 6 Trial Software for your computer operating system.

3) Launch the FileMaker Pro 6 software.

4) Drag & Drop the FileMaker Pro 2,3,4 files onto the FileMaker Pro 6 software window.

Each file will be converted to a new file having the .fp5 file extension used by FileMaker Pro 6.

5) Proceed to the next step - FileMaker Pro 5,6 File Preparation.

FileMaker Pro 5,6 - File Preparation

1) Make a copy of each of your FileMaker Pro files. Changes will need to be made within each file 

and you always want to be able to return to your original copy in case a problem occurs.

Select File -> Save a Copy As... -> compacted copy (smaller)

2) Rename each saved filename so that it contains no spaces or special characters. The filename 

gets used as a tablename when it is used with the ODBC driver, and spaces and special 

characters are not permitted. Therefore a filename which was originally:

Asset Management.fp5

should be changed to:

Asset_Management.fp5

If you allowed FileMaker Pro to name the file when you saved a copy, you might have ended up 

with a filename like this:

Asset Management Copy.fp5

which should be changed to:

Asset_Management.fp5

It is confusing to be dealing with lots of files named ??? Copy.fp5, so just remove the word "Copy" 
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which was appended by FileMaker Pro when you saved the file.

3) Copy all of your files into a convenient location, like a new folder so that you can keep them 

together. You might name this folder: Modified_Files in order to keep them separate from the 

original files and the empty copies of the files which will be created later. In fact, you will probably 

want to create a top-level folder to keep track of all of the files/folders which will be created during 

the migration project. 

So you could create a folder named: FM_Migration_Project

This top-level folder can then serve as the Output Directory which you will select within FmPro 

Migrator. 

Notice that each of the folders doesn't contain spaces. Under some (rare) circumstances FmPro 

Migrator may need to run migration scripts via the command line and this process only works if 

there are no spaces within any of the the folder names leading to the Output Directory. 

Open each .fp5 file saved into the Modified_Files folder and make the following changes.

4) Delete all ScriptMaker Scripts.

Select the menu: 

Scripts -> ScriptMaker...

5) Delete all Relationships. 

Select the menu:

File -> Define Relationships...

Note: Relationships are only converted to SQL databases for FileMaker Pro 7+ file versions. You 

can potentially upgrade each file into an .fp7 file if you need this feature.

6) Delete all Passwords.

Select the menu:

File -> Access Privileges -> Passwords

Make sure that the remaining un-password protected access provides Full Access to the entire file, 

with all file options checked within the dialog box.

7) Delete all fields having the following types:

Global

Summary

Unstored Calculation

Select the menu:

File -> Define Fields...

It is necessary to delete these fields from large database files having more than a few thousand 

records because the amount of time required for FileMaker Pro to perform the calculations may 

exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 
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exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 

FileMaker Pro to the destination database.

Note: You may leave the Stored Calculation fields, as the data may be valuable within the 

destination database.

It will take some work to delete recursive field dependencies. You could make one pass thru the 

fields from top to bottom to delete all of the fields which can be deleted, and then make another 

pass thru the fields list from the bottom up to the top of the list.

8) Once all of the unneeded objects have been deleted from each file - make an empty copy of 

each file. You could store the empty copy of each file within a folder named Empty_Files.

This empty copy of the database files will be used for Step 1 of the migration process where you 

will Drag & Drop the empty files onto the Step 1 icon within FmPro Migrator. This will cause FmPro 

Migrator to read the structure of each file to start the migration process.

Select the menu:

File ->  Save a Copy As... -> clone (no records)

This empty copy of each file needs to have exactly the same name as the compacted copy you 

saved previously within the Original_Files folder.

This empty copy of the file will be used by FmPro Migrator for gathering the field info from each file. 

Saving an empty copy cleans up the internal structure of the file and reduces the size of the file 

which needs to be read by FmPro Migrator and speeds up the process compared to reading a full 

copy of the file.

FileMaker Pro 7+ - File Preparation

1) (Optional) Use FileMaker Pro Advanced to export a DDR XML file from each .fp7 file.

This step is only required if you want FmPro Migrator to export relationships from FileMaker Pro 

into the destination SQL database.

2) Make a copy of each of your FileMaker Pro files. Changes will need to be made within each file 

and you always want to be able to return to your original copy in case a problem occurs.

Select File -> Save a Copy As... -> compacted copy (smaller)

Saving a compacted copy of the file cleans up the internal structure of the file and reduces the size 

of the file by removing the indexes within the file.

If you allowed FileMaker Pro to name the file when you saved a copy, you might have ended up 

with a filename like this:

Asset Management Copy.fp7
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which should be changed to:

Asset Management.fp7

It can be confusing to deal with lots of files named ??? Copy.fp7, so just remove the word "Copy" 

which was appended by FileMaker Pro when you saved the file.

3) Copy all of your files into a convenient location, like a new folder so that you can keep them 

together. You might name this folder: Modified_Files in order to keep them separate from the 

original copy of the files. In fact, you will probably want to create a top-level folder to keep track of 

all of the files/folders which will be created during the migration project. 

So you could create a folder named: FM_Migration_Project

This top-level folder can then serve as the Output Directory which you will select within FmPro 

Migrator. 

Notice that each of the folders doesn't contain spaces. Under some (rare) circumstances FmPro 

Migrator may need to run migration scripts via the command line and this process only works if 

there are no spaces within any of the the folder names leading to the Output Directory. 

Open each .fp7 file saved into the Modified_Files folder and make the following changes.

4) Delete all ScriptMaker Scripts.

Select the menu: 

Scripts -> ScriptMaker... 

or

Scripts -> Manage Scripts...

5) Delete all Relationships and non-base table TOs on the RelationshipGraph

Select the menu:

File -> Define/Manage Database...

Click the Relationships tab.

Note: If it is necessary to change the names of TOs to match base table names, while maintaining 

the relationship structure of the file, then the DDR XML file should be re-exported after making 

these changes, but before actually deleting the relationships.

Since the DDR XML file has already been exported, none of the relationships are actually needed 

for the actual data transfer part of the migration process. The FileMaker ODBC driver needs to see 

TOs on the RelationshipGraph which exactly match the name of each base table listed on the 

Tables tab.

If there are a lot of TOs and relationships on the RelationshipGraph it may be easier to delete all of 

the objects on the RelationshipGraph and then simply recreate the TOs from the existing base 

tables within the file. This can be done by clicking the Add Table button and selecting the base 

table name for each base table.
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table name for each base table.

6) Define a Primary Key for each table.

Each table must have a primary key if you want to create relationships for the table in the SQL 

database or if you want to migrate repeating fields data.

FmPro Migrator identifies the Primary Key for each table by looking for the Unique and Not Empty 

field validation options being set for any field within the table. If there are primary key fields which 

don't have these attributes set, they should be set now.

Note: If you are using FileMaker Pro Advanced, you will be able to copy and paste the table 

definitions from FileMaker Pro into FmPro Migrator via the Clipboard. FmPro Migrator will then be 

able to gather all of the attributes for each field. These attributes are also obtained from the file 

when using AppleScript on Mac OS X. 

However if you are using the ODBC interface on Windows to gather table info during the Step 1 

processing, these extra attributes won't be gathered automatically. So in this situation the primary 

key attribute needs to be specified manually within FmPro Migrator. This can be done by 

double-clicking on the primary key field within the fields list, and clicking the primary key icon for 

the field.

If the migrated tables don't actually have any field which can serve as a primary key, then a new 

field should be added as an Auto-Enter Serial Number field within the table. Then each record can 

be renumbered in Browse mode starting with 1 by clicking in the new field and selecting the 

Records -> Replace field Contents... menu. Before renumbering the records, select the Records -> 

Show All Records menu.

Once again, if it is necessary to re-define primary keys and the associated relationships within the 

database, the DDR XML file should be exported again after making these changes, but before 

deleting the relationships from within the file.

7) Verify Primary Key and Foreign Key Data Types

It is possible (but not recommended) to create relationships within FileMaker Pro databases 

between Text and Numeric field types. SQL databases will usually not accept differing data types 

when creating relationships. The field types can be corrected within the Fields tab of the 

Define/Manage Database dialog.

8) Verify Admin Account Access to File

Select the menu:

File -> Manage Accounts & Privileges

In order to transfer data from FileMaker Pro using the ODBC driver, it is necessary for FmPro 

Migrator to log into the FileMaker Pro database using a password having [Full Access] including 

ODBC access privileges within the file. The built-in Admin account already has [Full Access] 

privileges within the file, but these privileges could have been changed after the file was originally 
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privileges within the file, but these privileges could have been changed after the file was originally 

created. FileMaker 2,3,4,5,6 files may not even have an Admin account with [Full Access] 

privileges by default, depending upon how the user accounts were created within the original file.

9) Delete all fields having the following types:

Global

Summary

Unstored Calculation

Select the menu:

File -> Define/Manage Database...

It is necessary to delete these fields from large database files having more than a few thousand 

records because the amount of time required for FileMaker Pro to perform the calculations may 

exceed the ODBC driver timeout interval. If this problem occurs, no records will be transferred from 

FileMaker Pro to the destination database. The deletion of Global fields is not mandatory, but since 

Global fields don't exist within SQL databases they should be removed in order to reduce the field 

count.

Note: You may leave the Stored Calculation fields, as the data may be valuable within the 

destination database.

It will take some work to delete recursive field dependencies. You could make one pass thru the 

fields from top to bottom to delete all of the fields which can be deleted, and then make another 

pass thru the fields list from the bottom up to the top of the list.

Exporting DDR XML File

Using FileMaker 7+, select Database Design Report... from the Tools menu.

Note: Export the DDR file for the database to be migrated before removing Relationships and 
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Table Occurrences from the Relationship Graph. 

This DDR file will be used for importing Relationships, TOs, Value Lists, Custom Functions and 

Layouts into FmPro Migrator Developer Edition.

Exporting DDR XML File - Selecting Output Options

Within the DDR Export dialog, make sure that the database file is (1) checked for export, (2) along 

with all objects, (3) XML instead of HTML report format, then click the (4) Create button.
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Exporting DDR XML File - Selecting Output Directory

Select the output directory, then click the Save button.
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Pre-Migration Task - Delete Unstored Calc Fields

Prior to transferring data from a FileMaker Pro database into a SQL database is is usually 

necessary to delete all Unstored Calculation and Summary fields from the FileMaker Pro database 

tables. This step is usually necessary when transferring more than a few thousand records 

because the amount of time required for FileMaker Pro to calculate these values may cause an 

ODBC timeout, thus preventing the data from being transferred at all. This step should be 

completed before Step 2 - Get Fieldsize is run.

FmPro Migrator includes an automated field deletion feature which can help with this task. 
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Open Manage Deleted Fields Window

Once the FileMaker table definitions have been imported via the clipboard, the list of tables will be 

displayed within the Migration Process window.

1) Double-click on the table name, the Table Details window will be displayed. Click on the 

Manage Deleted Fields button near the top of the Table Details window, the Manage Deleted 

Fields window will open.

3) Click on the Mark for Deletion Button, all of the Unstored Calculation, Summary and Global 

fields in the selected table will be marked for deletion. Note: Global fields are also marked for 

deletion in order to reduce the number of fields of data to speed up the data transfer process. For 

the example table shown in this screenshot, there were 15 fields marked for deletion. At this point, 

the fields have not yet been deleted, they have just been marked for deletion.
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Delete Fields

1) Click the Delete Fields button. FmPro Migrator will first print a list of the ALTER TABLE SQL 

commands in the Results window, then the ALTER TABLE commands will be sent directly to the 

FileMaker database thru the ODBC connection. An example of these commands is listed below.

Note: It is common for some DROP COLUMN commands to fail as a result of Outstanding 

References by other fields. In order to resolve this issue, FmPro Migrator logs the failed DROP 

COLUMN commands and then re-sends those commands to the FileMaker Pro database again, in 

reverse order during Pass #2 processing. If PASS #2 still results in DROP COLUMN command 

failures, the remaining list of undeleted fields will be listed at the end of the processing. 

Click on the Clipboard icon to copy the commands any other software for review purposes. It will 

be helpful to have these field names available when deleting the fields manually. It is necessary to 

manually delete any fields which were not deleted automatically in order to proceed with Step #2 - 

Get Fieldsize.

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Cost"

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Book Value"

ALTER TABLE "tbl_Assets" DROP COLUMN "Total Depreciation"

ALTER TABLE "tbl_Assets" DROP COLUMN "Template Information Global"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLibrary"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSortedBy"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteCategory"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteAssignedTo"
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ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteItem"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteModel"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSerialNumber"

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLocation"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_Full_URL_ReadWrite"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_Full_URL_ReadOnly"

ALTER TABLE "tbl_Assets" DROP COLUMN "SC_URL_Prefix"

Field 1 of 15 Processed [Pass #1].

Field 2 of 15 Processed [Pass #1].

Field 3 of 15 Processed [Pass #1].

Field 4 of 15 Processed [Pass #1].

Field 5 of 15 Processed [Pass #1].

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteLibrary"

[FileMaker][FileMaker]  (13): Outstanding references

Field 6 of 15 Processed [Pass #1].

ALTER TABLE "tbl_Assets" DROP COLUMN "HiliteSortedBy"

[FileMaker][FileMaker]  (13): Outstanding references

Field 7 of 15 Processed [Pass #1].

Field 8 of 15 Processed [Pass #1].

Field 9 of 15 Processed [Pass #1].

Field 10 of 15 Processed [Pass #1].

Field 11 of 15 Processed [Pass #1].

Field 12 of 15 Processed [Pass #1].

Field 13 of 15 Processed [Pass #1].

Field 14 of 15 Processed [Pass #1].

Field 15 of 15 Processed [Pass #1].

Field 1 of 2 Processed [Pass #2].

Field 2 of 2 Processed [Pass #2].

----------      Completed     ----------
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Adding Deleted Fields to the SQL Database [PHP Conversion Only]

After the table has been created in the SQL database, and the data transferred to the SQL 

database, the deleted columns can then be added to the SQL database table. 

Note: This step is only needed if a PHP Conversion project is being generated, in order to insure 

that the database columns referenced in the CakePHP Model files exist within the database table.

ALTER TABLE tbl_assets ADD total_cost DOUBLE NULL;

ALTER TABLE tbl_assets ADD total_book_value DOUBLE NULL;

ALTER TABLE tbl_assets ADD total_depreciation DOUBLE NULL;

ALTER TABLE tbl_assets ADD template_information_global TEXT NULL;

ALTER TABLE tbl_assets ADD hilitelibrary BLOB NULL;

ALTER TABLE tbl_assets ADD hilitesortedby TEXT NULL;

ALTER TABLE tbl_assets ADD hilitecategory BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteassignedto BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteitem BLOB NULL;

ALTER TABLE tbl_assets ADD hilitemodel BLOB NULL;

ALTER TABLE tbl_assets ADD hiliteserialnumber BLOB NULL;

ALTER TABLE tbl_assets ADD hilitelocation BLOB NULL;

ALTER TABLE tbl_assets ADD sc_full_url_readwrite TEXT NULL;

ALTER TABLE tbl_assets ADD sc_full_url_readonly TEXT NULL;

ALTER TABLE tbl_assets ADD sc_url_prefix TEXT NULL;

Field 1 of 15 Processed.

Field 2 of 15 Processed.

Field 3 of 15 Processed.
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Field 4 of 15 Processed.

Field 5 of 15 Processed.

Field 6 of 15 Processed.

Field 7 of 15 Processed.

Field 8 of 15 Processed.

Field 9 of 15 Processed.

Field 10 of 15 Processed.

Field 11 of 15 Processed.

Field 12 of 15 Processed.

Field 13 of 15 Processed.

Field 14 of 15 Processed.

Field 15 of 15 Processed.
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ODBC Driver Installation
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Install FileMaker ODBC Driver - MacOS X (FileMaker 7,8,910)

Copy SequeLink.bundle File to /Library/ODBC

For FileMaker 7+ Databases on MacOS X:

Manually copy the SequeLink.bundle file from the ODBC Client Driver folder on the FileMaker 

application CD or ESD dmg to the /Library/ODBC folder within MacOS X.

Note: Using the FileMaker ODBC driver with FileMaker Pro/Advanced 7+ requires the FileMaker 

database file and ODBC driver to be open locally on the same computer where FmPro Migrator is 

running. The exception to this requirement is when the database file is opened with FileMaker 

Server Advanced. 

Download & Install iODBC Driver Administrator from OpenLink Software

Download and install the iODBC Data Source Administrator, provided by OpenLinkSoftware, 

available from (www.openlinksw.com). Downloading the iODBC framework or any trial version of 

an OpenLink Software ODBC driver for MacOS X will provide you with the iODBC Driver Manager. 

The iODBC driver manager does not stop working after the trial software expires. The iODBC 

driver manager provides a test feature which enables you to quickly test ODBC driver connections 

after creating or updating an ODBC DSN.
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Add the Driver

Open the OpenLink ODBC Administrator application, (1) click on the ODBC Drivers tab, then (2) 

click the Add a driver button.
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Specify Name and Pathname to Driver

(1) Enter a descriptive name for the driver, this is a name which you will select when creating an 

ODBC DSN which uses the driver. (2) Enter the full pathname to the ivslk component within the 

SequeLink.bundle file.

This image shows part of the pathname to use for a FileMaker 9 ODBC driver, with the full 

pathname listed below:

/Library/ODBC/sequelink.bundle/contents/macos/ivslk20.dylib

The name of the ivslk component changes with each revision of the DataDirect SequeLink driver 

file. You can't count on it staying the same, so it is recommended that you navigate to the location 

of the SequeLink.bundle file and select Ctrl + Show Package Contents to view the contents of the 

MacOS folder.  Clicking the Browse button to the right of the Driver file name field doesn't allow the 

selection of individual components within bundle files. You always need to manually type in this 

pathname.
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(3) Click the Ok button, and the driver will be added to the list of available ODBC Drivers.

If the driver doesn't get added, try to close, then reopen the ODBC Administrator program.

Add a System DSN

(1) Click the System DSN tab, then (2) click the Add button.
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Choose FileMaker ODBC Driver

(1) Select the FileMaker 9 ODBC driver from the list, (2) click the Finish button.
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Enter System DSN Parameters

(1) Enter the name of the DSN, this name must match the name shown within FmPro Migrator for 

the FileMaker Pro database. (2) Enter the Port, (3) Host, (4) ServerDataSource and (5) 

ServerDataName. Each Keyword and Value needs entered manually in the Keyword and Value 

fields. (6) After entering each Keyword/Value pair, click the Add button and the values will appear 

in the list of Keyword/Value pairs.

(7) Click the Ok button to create the System DSN.

Note: Setting up the ServerDataSource and ServerDataName values with "Default" values, 

enables multiple individual FileMaker Pro files to be used with the driver, without requiring a 

change to be made to the ODBC DSN parameters. However the limitation associated with this 

configuration is that only one FileMaker Pro database file can be used at one time with the ODBC 

driver. Having two database files open at the same time confuses the ODBC driver (even if a table 

name is specified to the driver) causing none of the tables within any of the open files to be found 

by the ODBC driver.
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Enable ODBC/JDBC Sharing within FileMaker Pro

ODBC/JDBC Sharing needs to be enabled within any FileMaker Pro database file which is going 

to be used with the FileMaker ODBC driver.
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Select Sharing Parameters

(1) Turn on ODBC/JDBC Sharing, (2) for the currently open FileMaker Pro database file, (3) for All 

Users, then (4) click the Ok button.

Test ODBC DSN

(1) Click the System DSN which has just been created, (2) click the Test button.
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Enter the (1) Username, (2) Password, then (3) click the Ok button to test the ODBC DSN.

If the test passes, this dialog will be displayed, showing that the ODBC Driver Manger has used 

this ODBC DSN to successfully connect to the FileMaker database.

If the test fails:

1) Re-verify the pathname to the svlk file within the SequeLink.bundle file.

2) Verify that the FileMaker database file is open.

3) Verify that ODBC sharing is enabled for the account entered in the connection test dialog 

prompt.

4) Make sure that there aren't two different copies of FileMaker running at the same time. Both 

older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 

of conflict occurs, close both versions of the FileMaker application, and only open the one copy 

you want to serve the database file being migrated.

5) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 

Then test the DSN again after rebooting.
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Install FileMaker ODBC Driver - MacOS X (FileMaker 11+)

Download ODBC Manager

Download and install the free ODBC Administrator for MacOS X from www.odbcmanager.net

You will use the ODBC Administrator to create and manage your ODBC DSNs on MacOS X.

http://www.odbcmanager.net
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Install the FileMaker ODBC Driver

(1) Open the xDBC folder on the FileMaker install CD (or installer image DMG file).

(2) Double-click the FileMaker ODBC.mpkg installer to install the FileMaker ODBC driver. Follow 

the insular prompts.
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Add a System DSN

(1) Click the System DSN tab, then (2) click the Add button.

Choose the FileMaker ODBC Driver

(1) Select the FileMaker ODBC driver from the list, (2) click the Ok button.
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FileMaker ODBC DSN Configuration - Page 1

Click the Continue button.
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FileMaker ODBC DSN Configuration - Page 2

(1) Enter a name for the FileMaker ODBC DSN. The name used here needs to be exactly the same 

as the ODBC DSN Name you enter into FmPro Migrator. 

(2) Click the Continue button.

Note: You can pick a different name than you see here, just make sure that you enter exactly the 

same name into FmPro Migrator.
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FileMaker ODBC DSN Configuration - ODBC DSN Field in FmPro Migrator

In this screenshot, the FileMaker 11 database is the destination database, therefore the FileMaker 

ODBC DSN name is entered in the Destination Database ODBC DSN field.

If the FileMaker database was the source database, and the data was being copied to a different 

database server, then the FileMaker ODBC DSN would be entered into the ODBC DSN field for 

the Source Database (not shown in this screenshot).
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FileMaker ODBC DSN Configuration - Page 3

(1) Enter the hostname for the FileMaker database (default is localhost).

(2) Click the Continue button.

For a file which has been opened on your local desktop machine, leave the default setting of 

localhost.

For a hosted file hosted by FileMaker Server Advanced, enter the IP Address or hostname of the 

FileMaker Server Advanced computer.
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FileMaker ODBC DSN Configuration - Page 4

(1) For most locally hosted database files, enter the text "Default" into the Database field, instead of 

selecting a database from the list. This way you can use any single database file without 

re-selecting the database name each time you open a new file. 

To use this feature, you must only have one FileMaker database file open at a time, or an error will 

occur when attempting to read info from the database.

(2) Click the Advanced Language button.
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FileMaker ODBC DSN Configuration - Page 5

(1) Un-check the Auto-detect language settings checkbox.

(2) Select UTF-8 from the Multi-byte text encoding menu.

(3) Click the Ok button.
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FileMaker ODBC DSN Configuration - Page 4

(1) Click the Continue button.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 39

FileMaker ODBC DSN Configuration - Page 5

(1) Click the Test button.

If the test fails, use the following steps to enable ODBC sharing for the FileMaker database. 

Note: Each FileMaker database needs to have ODBC sharing enabled individually.

FileMaker ODBC DSN Configuration - Page 5 - ODBC DSN Test

Enter the (1) Username, (2) Password, then (3) click the Ok button to test the ODBC DSN.
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FileMaker ODBC DSN Configuration - Page 5 - ODBC DSN Test

(1) Click the Ok button.

If the test passes, this dialog will be displayed, showing that the ODBC Driver Manger has used 

this ODBC DSN to successfully connect to the FileMaker database.

If the test fails:

1) Verify that the FileMaker database file is open.

2) Verify that FileMaker ODBC sharing is enabled for the account entered in the connection test 

dialog prompt.

4) Make sure that there aren't two different copies of FileMaker running at the same time. Both 

older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 

of conflict occurs, close both versions of the FileMaker application, and only open the one copy 

you want to serve the database file being migrated.

5) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 

Then test the DSN again after rebooting.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 41

FileMaker ODBC DSN Configuration - Page 5

(1) Click the Done button to save the new ODBC DSN.
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Enable ODBC/JDBC Sharing within FileMaker Pro

ODBC/JDBC Sharing needs to be enabled within any FileMaker Pro database file which is going 

to be used with the FileMaker ODBC driver.
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Select Sharing Parameters

(1) Turn on ODBC/JDBC Sharing, (2) for the currently open FileMaker Pro database file, (3) for All 

Users, then (4) click the Ok button.
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Install FileMaker ODBC Driver - Windows - FileMaker 7,8,9,10

Install FileMaker ODBC Driver

Run the DataDirect SequeLink installer, within the xDBC/ODBC Client Driver Installer folder on the 

FileMaker Pro installation CD. Follow the prompts to install the FlleMaker ODBC Driver. 

Create ODBC DSN

To create a new System ODBC DSN, open the Control Panel > Administrative Tools > Data 

Sources (ODBC) Control Panel.
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(1) Click the System DSN tab, then (2) click the Add button.

(1) Select the DataDirect 32-BIT SequeLink driver, then (2) click the Finish button.

If the DataDirect 32-BIT SequeLink driver does not appear within the list of available drivers, 

please refer to FileMaker Technical Support Knowledge Base record #357 for more details about 

the driver installation process.
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(1) Enter the Data Source Name, (2) SequeLink Server Host, (3) SequeLink Server Port, then (4) 

click on the Server Data Source button.

Set Data Source = Default

(1) Click the item named "Default", then (2) click the Ok button. Don't select the actual name of the 

database shown in the list, or you will have to change the database name for each individual 

database file which you want to use with this ODBC DSN. Selecting the Default item in the list 

insures that you will always be able to open any FileMaker database file regardless of its name, as 

long as ODBC sharing is enabled.

Note: Setting up the Server Data Source value to the "Default" value, enables multiple individual 

FileMaker Pro files to be used with the driver, without requiring a change to be made to the ODBC 

DSN parameters. However the limitation associated with this configuration is that only one 
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FileMaker Pro database file can be used at one time with the ODBC driver. Having two database 

files open at the same time confuses the ODBC driver (even if a table name is specified to the 

driver) causing none of the tables within any of the open files to be found by the ODBC driver.

Enable ODBC/JDBC Sharing within FileMaker Pro

ODBC/JDBC Sharing needs to be enabled within any FileMaker Pro database file which is going 

to be used with the FileMaker ODBC driver.
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Select Sharing Parameters

(1) Turn on ODBC/JDBC Sharing, (2) for the currently open FileMaker Pro database file, (3) for All 

Users, then (4) click the Ok button.

Test ODBC DSN

Click the Test Connect button, enter the Username/Password to connect to the FileMaker 

database file which is currently open. 
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If the test fails:

1) Verify that the FileMaker database file is open.

2) Verify that ODBC sharing is enabled for the account entered into the connection test dialog 

prompt.

3) Make sure that there aren't two different copies of FileMaker running at the same time. Both 

older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 

of conflict occurs, close both versions of the FileMaker application, and only open the one copy 

you want to serve the database file being migrated.

4) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 

Then test the DSN again after rebooting.

Click the Ok button to save changes and create the new System DSN.
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Install FileMaker ODBC Driver - Windows - FileMaker 11+

Install the FileMaker ODBC driver from within the xDBC folder on the installation CD or CD image 

file.

Create ODBC DSN - Windows

To create a new System ODBC DSN, open the Control Panel > Administrative Tools > Data 

Sources (ODBC) Control Panel.
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(1) Click the System DSN tab, then (2) click the Add button.

Select ODBC Driver - FileMaker 11 - Windows

(1) Select the FileMaker ODBC driver, then (2) click the Finish button.
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ODBC Driver Configuration - FileMaker 11 - Windows (1)

Click Next button.

Click the About button if you need to find the version number for the driver.

ODBC Driver Configuration - FileMaker 11 - Windows (2)

1) Enter a name for the ODBC DSN, (2) click the Next button.
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ODBC Driver Configuration - FileMaker 11 - Windows (3)

1) If you are using a local copy of FileMaker Pro or FileMaker Pro Advanced, then use "localhost" 

as the host name. Otherwise use the IP address or hostname of the FileMaker Advanced Server.

2) You may optionally click the "Connect to host ..." button to get a list of database files.

3) Click the Next button.
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ODBC Driver Configuration - FileMaker 11 - Windows (4)

1) Enter "Default" as the database name. Or if you have multiple database files open locally or on 

the server, then select the database name from the list or enter the name of the database. Using 

the Default keyword means that you can avoid changing the setup of the ODBC DSN when using 

different database files - but it means that only one file can be open at a time.

2) Click the Advanced Language button.

ODBC Driver Configuration - FileMaker 11 - Windows (5)

1) Uncheck the "Auto-detect language settings" button, 2) select System (WinLatin1) for the text 

encoding, 3) click the Ok button.
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It has been found that for proper character encoding, the following configuration works well:

1) Install the FileMaker database and FmPro Migrator on Windows. If using a 64-bit version of 

Windows, use the ODBC Administrator - 32 bit (not the 64 bit) to create your ODBC DSN when 

using FileMaker Pro or FileMaker Pro Advanced.

2) In the FileMaker ODBC driver, disable the Auto-Detect Language checkbox in the Advanced 

Language dialog.

3) Set the Multi-byte Text Encoding menu to System(WinLatin1) in the Advanced Language dialog.

4) Enable the Perform Translation for Character Data checkbox on the last panel of the SQL 

Server ODBC DSN configuration.

ODBC Driver Configuration - FileMaker 11 - Windows (6)

Click the Next button.
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ODBC Driver Configuration - FileMaker 11 - Windows (7)

Click the Test button.

ODBC Driver Configuration - FileMaker 11 - Windows (8)

1) Enter Username, 2) Password (if needed), 3) click the Ok button.

Review the test results, make corrections as necessary until the test passes.

ODBC Error Troubleshooting Steps:

1) Verify that the FileMaker database file is open.

2) Verify that ODBC sharing is enabled for the account entered in the connection test dialog 

prompt.

3) Make sure that there aren't two different copies of FileMaker running at the same time. Both 

older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 

of conflict occurs, close both versions of the FileMaker application, and only open the one copy 
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you want to serve the database file being migrated.

4) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 

Then test the DSN again after rebooting.

ODBC Driver Configuration - FileMaker 11 - Windows (9)

Click the Finish button.
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Step 1
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Step 1 - Get Info - Oracle

Oracle Instructions

Revision 03

9/6/2013

[Added Manage Deleted Fields Info]

Step 1 - Install FileMaker ODBC Driver

FmPro Migrator uses the FileMaker ODBC driver provided by FileMaker Inc. to transfer data from 

FileMaker databases. 

For FileMaker 5/6 Databases on Windows:

The FileMaker ODBC driver is installed automatically when the FileMaker application is installed. 

This driver is installed with the Demo and Full versions of the FileMaker application. If you are 

converting FileMaker 2, 3 or 4 database files, upgrade these files into FileMaker 5/6 files in order 

to perform the migration.

For FileMaker 7+ Databases on Windows:

Install the DataDirect SequeLink driver using the installer located in the xDBC folder on the 

FileMaker application CD. Do not download and install the DataDirect SequeLink driver from the 

Datadirect website. The FileMaker ODBC driver is only supplied on the FileMaker installation CD 

or the FileMaker ESD (downloadable CD image) with the fully licensed versions of FileMaker Pro, 

FileMaker Developer 7, FileMaker Advanced and FileMaker Server Advanced.

For FileMaker 2, 3, 4, 5, 6 Databases on MacOS X:

Upgrade these database files to FileMaker 7+, use the FileMaker 7+ ODBC driver on MacOS X.

For FileMaker 7+ Databases on MacOS X:

Manually copy the SequeLink.bundle file from the ODBC Client Driver folder on the FileMaker 

application CD or ESD dmg to the /Library/ODBC folder within MacOS X.

Note: Using the FileMaker ODBC driver with FileMaker Pro/Advanced 7+ requires the FileMaker 

database file and ODBC driver to be open locally on the same computer where FmPro Migrator is 

running. The exception to this guideline is when the database file is opened with FileMaker Server 

Advanced. 
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Step 1 - Get Info - Select FileMaker tab

Launch FmPro Migrator, then click on the FileMaker tab at the top of the window.

Step 1 - Get Info - Select Output Directory

FmPro Migrator stores migration process information within a SQLite database file named 

MigrationProcess.db3. This file contains the metadata for the source database file(s), including 

tables, fields, relationships, table creation SQL code and status info. Therefore the first step in the 
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migration process is to select the Browse button to select the output folder FmPro Migrator will use 

when creating the MigrationProcess.db3 file.

Continue Migration...

Tip: To restart an existing migration project, select the output directory, then select Continue 

Migration... from the File menu.

Click the yellow Continue button to open the Migration Process window.

Step 1 - Get Info - Enter Source Database Info

Select the type of source database from the Source Database menu.

Note: Since there isn't a MacOS X compatible FileMaker ODBC driver for FileMaker 5/6, these 

older database files should be converted to FileMaker 7 or higher in order to perform the migration 

on MacOS X.

Either use the existing ODBC DSN name "example_fmp_dsn" or change this name to reflect the 

name of a System ODBC DSN you have created on your computer.
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Enter the Username and Password required to access the source database file. If a password has 

not been configured within a FileMaker 7+ file, set the username to "Admin" with the password 

field empty. The user account entered here needs to have full access to the database file and 

needs to have ODBC access privileges within the file. This is the default access for the Admin 

account.

Step 1 - Get Info - Enter Destination Database Info

(1) Select Oracle as the destination database type. Once the destination database has been 

selected, a new set of fields will become visible for entering the connection parameters for the 

destination database.

The destination database may located either locally or remotely. Enter the (2) ODBC DSN name, 

(5) database name, (6) username, (7) password.

Note1: It is not necessary to enter/change the (3) hostname or (4) TCP/IP Port number for Oracle 

databases since this connection to the database is defined within the ODBC DSN.

Note2: Make sure that the Oracle database account entered in field (5) has full access to the 

Oracle database. This account should have all privileges granted in order for FmPro Migrator to be 

able to create/drop tables and insert data. 
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Step 1 - Get Info

FmPro Migrator needs to get info about tables, fields, field types and repeating fields status within 

the source FileMaker database file(s). This info is used to create the tables/fields within the 

destination database and is used to copy data between the databases.

There are multiple ways methods FmPro Migrator can use to get info about the source database 

file, as listed below. Use the method which works best for your computer OS and the version of the 

FileMaker database file being migrated. 

Select the pop-up menu below the Step 1 Get Info icon to select the method you want to use to get 

info from the source database file(s).  This pop-up menu is context-sensitive, based upon the 

selected source database type and the platform where FmPro Migrator is running (MacOS X or 

Windows).

Step 1 - Get Info - Using Drag & Drop - MacOS X & Windows

FmPro Migrator reads the metadata directly from older FileMaker database files, including 

FileMaker 2, 3, 4, 5 and 6 on MacOS X and Windows. This method of getting info from FileMaker 

provides a very accurate representation of the source database file, including calculation formula 

definitions and repeating field counts for each field. 

Drag & Drop the empty copy of the source database file onto the Step 1 Get Info icon.

Repeat these steps for each source database file which needs migrated.

Note: Since there is no FileMaker ODBC driver available for older versions of FileMaker on MacOS 
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X, if you use this method to get info from your source database file(s), you will will then need to 

upgrade the file(s) to FileMaker 7+ prior to performing the migration. You will then need to change 

the source database type from FileMaker 5/6 to FileMaker 7+ within FmPro Migrator.

Step 1 - Get Info - Using ClipBoard XML - MacOS X & Windows

The most desirable method for obtaining info about FileMaker 7+ database files on MacOS X and 

Windows is thru copying the table structure using FileMaker Advanced (version 8+). This method 

copies the table creation XML code from the clipboard and includes all of the info required to 

create the tables, fields, repeating field count and calculation formulas.

Open the FileMaker database file.

Select Define/Manage Database from the File menu within FileMaker Pro Advanced.
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Step 1 - Get Info - Copy Table XML

(1) Select all of the tables on the Tables tab, (2) click the Copy button.

Once the Table XML info has been put onto the ClipBoard, the Paste button will become active. 

Click the Cancel or Ok buttons to close the Define/Manage Database dialog.
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Step 1 - Get Info - Continue Button

Within FmPro Migrator, click the Step 1 Get Info button (with the ClipBoard XML menu option 

selected). The yellow Continue... button will become visible once FmPro Migrator has completed 

processing the Table XML from the ClipBoard.

Step 1 - Get Info - Using AppleScript - MacOS X

On MacOS X, AppleScript can be used to gather Table/Field info from FileMaker 7+ databases. 

AppleScript is slower than copying the Table XML via the ClipBoard, and may take several 

minutes to gather info for large databases containing many tables and fields. Using AppleScript 
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does provide valuable info such as calculation formulas and repeating fields count info.

1) Open the FileMaker database file.

2) If necessary, click the Select button to select FileMaker Pro from the list of running applications. 

It is not usually necessary to perform this step, and is generally only required if an error occurs. 

The FileMaker Pro application name has changed thru the years (sometimes FileMaker 

Developer, FileMaker Pro, FileMaker Pro Advanced), but now seems stable as the name 

FileMaker Pro - unless you have renamed the application on your computer. Now, even FileMaker 

Pro Advanced shows up as FileMaker Pro according to AppleScript.
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Click the Step 1 Get Info button, with AppleScript selected from the pop-up menu. FmPro Migrator 

will send AppleScript commands to the open FileMaker database file(s) and gather info about 

each file. The yellow Continue... button will be made visible once this process has completed.
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Step 1 - Get Info - Using ODBC - Windows

An alternative method for getting info from source FileMaker 7+ databases is by using ODBC on 

Windows. This method is less desirable compared to using the ClipBoard XML method, because 

repeating field count values are not obtained thru an ODBC connection. The repeating fields need 

to be defined manually within the Migration Process Field Details window.

Open the FileMaker database file.

Create an ODBC System DSN matching the ODBC DSN name shown for the Source Database.

Enable ODBC sharing within FileMaker. Select the File > Sharing > ODBC/JDBC...  menu.
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(1) Turn on sharing for  (2) All users, (3) click the Ok button.

Click the Step 1 Get Info button. The table structure info will be read from the source database file, 

and written into a newly created MigrationProcess.db3 file. The yellow continue button will then 

become visible.
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Step 1 - Get Info - Click Continue... Button

Regardless of the method used to gather info from the source FileMaker database or table, FmPro 

Migrator will make the yellow Continue... button visible once it has gathered info from the first 

FileMaker database. Click this button to open the Migration Process window and continue on to 

Step 2 of the migration process.
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Step 2
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Step 2 - Get Fieldsize

Step 2 - Get Fieldsize - Window Features

(1) Click on a table in the Tables list. Once a table is selected, a list of fields contained within the 

table will be displayed in the Fields list. These fields represent the info gathered from the source 

database by FmPro Migrator. 

(2) Clicking the Table Details button opens the Table Details window, which enables you to view 

and make changes to the individual parameters for the table.

(3) The Field Details button provides you with the ability to view and make changes at the field 

level.
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Step 2 - Get Fieldsize

Click the Step 2 Get Fieldsize button. FmPro Migrator will make an ODBC connection to the source 

FileMaker Pro database, and put up a progress dialog as it is reading thru the records. After the 

records have been successfully read from the table, the status menu at the bottom of the Step 2 

button will change from "Not Started" to "Completed".  The status will be set to "Failed" if the Get 

Fieldsize step fails for some reason.

If the Get Fieldsize step fails:

1) Check to make sure that the source database is open within FileMaker Pro/Advanced on the 

local computer.

2) Make sure that ODBC sharing is enabled.

3) For FileMaker 7+ databases, make sure that there is a TO on the RelationshipGraph which 

exactly matches the name of the base table being queried by FmPro Migrator.

4) Open the Define/Manage Database dialog and verify the existence of the base table within the 

FileMaker Pro database.
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Step 3
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Step 3 - Create Table - Oracle

Once the Get Fieldsize step has been completed, FmPro Migrator has enough information to 

create the SQL code defining the table in the destination database. The fieldsize info is 

automatically used to create table columns of the correct size when creating the table in the Oracle 

database. 

Text fields containing more than 255 characters are converted to Oracle CLOB columns and 

FileMaker Pro container fields are converted into Oracle BLOB columns.

Step 3 - Create Table

Click the Step 3 Create Table button to create the table in the destination database.

FmPro Migrator will generate the table creation SQL code, connect to the destination database 

and create the table. Once the table has been successfully created, the status menu under the 

Step 3 Create Table button will be changed to "Completed".



FmPro Migrator - FileMaker to Oracle Migration Procedure - 77

Holding down the shift key while clicking the Step 3 Create Table button drops and re-creates the 

table in the destination database. 

Warning: Dropping the table in the destination database causes the loss of all data within the 

table.

Step 3 - Create Table - IN or OUT Parameter Error [Mac OS X]

On Mac OS X, the "Missing IN or OUT parameter" error dialog may be displayed when sending the 

trigger SQL code to the Oracle database. If this occurs, open the Table Creation SQL Details 

window in order to copy and paste the contents of the Post Table Creation SQL code field into 

another tool for running the SQL code.
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     Step 3 - Table Creation SQL Details

if problems occur while creating the table in the destination database, you can review the table 

creation SQL code generated by FmPro Migrator by clicking the Table Creation Details button, 

next to the Step 3 Create Table icon.
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     Step 3 - Create Table - Table Creation Details Window

From within the Table Creation Details window, the Table Creation SQL code can be (1) manually 

edited, (2) saved or (3) re-executed in the Oracle database. The table can also be (4) dropped in 

the Oracle database.

The Post Table Creation SQL code can also be (5) manually edited, (6) executed, and (7) saved.

Clicking the (8) refresh button re-loads the previously stored version of the SQL code from the 

SQLite database.
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Fixing Duplicate Column Errors

During the creation of tables within the SQL database, table and field names may get truncated to 

match the maximum column length for the destination database server. This problem is especially 

common when working with Oracle, DB2 and Sybase servers due to the 30 character size limit for 

column names.

Table names should be shortened manually within FileMaker, due to the typically small number of 

tables found in most solutions. It is best to perform this task before copying tables into FmPro 

Migrator, or exporting a DDR XML file.

Due to the potential for having large numbers of fields within the FileMaker database tables, 

FmPro Migrator includes an automated process for shortening the column names. This process 

also tracks these changes thought the generation of new tables, and application code (PHP, .NET, 

LiveCode etc).

You may either use FmPro Migrator's automated renaming process, or you may use the info to 

manually change the column names in the FileMaker database.

Fix Duplicate Columns... Menu Item

If a problem is encountered with duplicate column names while creating tables in the destination 

database, select the File -> Fix Duplicate Columns... menu.
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Fix Duplicate Columns Window

Click the "Fix Column Names" button to read the list of tables/fields from the MigrationProcess.db3 

project file.
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List of Renamed Columns

Once the database schema has been read, a list of changed columns will be generated and 

displayed in the scrolling list field. The contents of this field can be exported into a spreadsheet file 

by clicking on the Export List button. 

The contents of this column mapping field will be stored within the MigrationProcess.dat file, and 

read into memory automatically whenever the MigrationProcess.db3 project file is opened.
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Step 4
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Step 4 - Transfer Data

Step 4 - Transfer Data

Click the Step 4 Transfer Data button to transfer data from the source table in the FileMaker 

database to the newly created table in the destination database. Once the data has been 

transferred successfully, the status menu below the Step 4 Transfer Data button will change from 

"Not Started" to "Completed".
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     Step 4 - Transfer Data - Troubleshooting

If the data transfer process fails, an error message will be displayed containing the text of the error 

message returned by the destination database. 

Some of the most common data transfer errors include:

FileMaker numeric fields containing non-numeric data.

FileMaker date fields containing non-date/time data.

FileMaker primary key fields containing duplicate or empty values.
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     Step 4 - Transfer Data - Troubleshooting - Non-Numeric Data Type Error

The FileMaker application is very forgiving of the types of data which can be entered into each 

field. Therefore it is possible for non-numeric data to be entered into numeric fields if field 

validation has not been enabled for these fields. However SQL databases generally won't accept 

non-numeric data within numeric fields, which will cause an error during the data transfer process.

If this type of error occurs:

Option 1: Correct the data within the FileMaker database in order to resolve the problem. Then 

drop and re-create the table in the destination database and click the Step 4 Transfer Data button 

again.

Option 2: Correct the data after transferring the data to the destination database. To get the data 

transferred to the destination database, click the Set Numeric Fields to Text button, above the 

Fields list. This button instructs FmPro Migrator to change all of the numeric field types to varchar 

field types in the table creation SQL code for the destination table. 
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     Step 4 - Transfer Data - Lock Table Details

After clicking the Numeric to Varchar, Date to Varchar or Varchar to TEXT buttons, open the Table 

Details window and click the lock icon. Setting the lock icon prevents FmPro Migrator from 

re-setting the field types back to their original values when clicking the Step 3 Create Table button.

Hold down the Shift key and click the Step 3 Create Table button to drop and re-create the table in 

the destination database, then click the Step 4 Transfer Data button again.

Note: You must generate table creation SQL code by clicking the Step 3 Create Table button at 

least once, before clicking the lock icon on the Table Details window.
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     Step 4 - Transfer Data - Troubleshooting - Non-Date/Time Data Type Error

If data transfer errors occur as a result of having non-date/time data within Date/Time fields, 

clicking the Set Date/Time Fields to Varchar button will change these column types to varchar 

columns in the destination database.

Open the Table Details window, click the Lock icon, then hold down the Shift key while clicking the 

Step 3 Create Table button.
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     Step 4 - Transfer Data - Varchar to TEXT Conversion

It is not usually necessary to change Varchar columns to TEXT column types in the destination 

database. But occasionally you might need to perform this task. If you wanted to perform a quick 

migration, without running the Get Fieldsize step, you could just convert all of the Varchar columns 

to TEXT column types without worrying about the exact size of the data being transferred. FmPro 

Migrator will utilize the correct column type in the destination database for storing the largest 

amount of text.

After clicking the Varchar to TEXT button, open the Table Details window, click the Lock icon, then 

hold down the Shift key while clicking the Step 3 Create Table button. This process will drop and 

re-create the table in the destination database, creating the new table with the requested column 

type changes.
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Step 4 - Transfer Data - Troubleshooting

Error Message: Count Error (1). 

If an unexpected error occurs during the data transfer process, there is an alternate data transfer 

process built into FmPro Migrator which can be used. Hold down the shift key when clicking on the 

Transfer Data button. The alternate data transfer method will open a separate console window and 

will run a compiled Perl program to transfer the data between databases.

If transferring data to an Access database, create an ODBC DSN to the destination database, as 

shown in the Table Details window. Open the Table Details window by double-clicking on the 

table in the list of tables. 
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Step 5
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Step 5 - Convert Data (Repeating Fields)

The buttons for Steps 5, 6 and 7 will only be visible if the source FileMaker Pro database table 

contains repeating fields.

FmPro Migrator converts non-relational repeating fields data into child records referencing the 

parent table record using the primary key of the parent table. The child table is created in the 

destination database using the naming convention parent_table_repeating. Each individual 

repeating fields data value is written into a separate record within this table.

Repeating Fields Processing - Preparation Steps

In order to accurately transfer repeating fields data, FmPro Migrator needs to determine the 

Primary Key field within the source FileMaker database table. FmPro Migrator identifies the 

Primary Key field as being a field in which Unique and Not Empty data validation is configured. 

The Primary Key field contains a "1" in the PK column as shown in the field list.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 93

If the Primary Key field contains empty or non-unique values, then the data needs to be corrected, 

or a new Primary Key field needs to be defined. Only one field should be defined as the Primary 

Key, and this field should be defined as a numeric field, as SQL databases don't generally handle 

Auto-Incrementing of Text and Numeric values within the same field (as FileMaker easily does).

To create a new Primary Key field within the FileMaker database, create a numeric field having 

Unique and Not Empty field validation. Disable the Unique and Not Empty validation for the 

original Primary Key field. 

Select the Records > Show All Records menu item, to make sure that all records will be affected by 

the Replace Field Contents feature.

After creating the new field, put the cursor into this new field, then select the Records > Replace 

Field Contents menu item.

Repeating Fields Processing - Creating New Primary Key

Using Replace Field Contents, replaces the empty values within the new Primary Key field with an 

incrementing series of numbers, within all records of the source table.

After adding this new Primary Key field and replacing field contents, you will need to start the 

migration process over starting with Step 1, since the structure of the source table has changed 

and FmPro Migrator needs to be aware of any changes which have been made to the source table.
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Step 5 - Convert Data (Repeating Fields) - FileMaker 7+ Only

For FileMaker 7+ source database tables, Step 5 processing is designed to change the contents of 

repeating fields data so that it can be transferred thru the FileMaker 7+ ODBC driver. FileMaker 7+ 

ODBC drivers are no longer capable of transferring data from repeating fields within the FileMaker 

database. To work-around this ODBC Driver limitation, FmPro Migrator moves all of the repeating 

fields data into the first repeating data value, and separates each repeat value with a TAB data 

separator. 

When the Step 5 Convert Data (Repeating Fields) button is clicked, FmPro Migrator generates a 

ScriptMaker scripts to convert the data within each repeating field data and puts this script onto the 

ClipBoard.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 95

Click the Ok button to the informational dialog.

Open the FileMaker ScriptMaker dialog, and paste the script from the ClipBoard into FileMaker.

Manually change each of the repeating fields from Numeric or Date/Time format to Text within 

FileMaker. It is not necessary to re-gather info from FileMaker after making this change.

Run the ScriptMaker script shown in the dialog (the one you just pasted into ScriptMaker).

Warning: Running the RF Convert script for a particular table is a task which should be performed 

one-time only. It should not be run more than once. To verify whether the RF Convert script has 

previously been run on a table, check to see if all of the repeating field data values have been 

moved to the first repeating field occurrence within the database.

     Step 5 - Convert Data (Repeating Fields) - Verifying Data Conversion

This image shows the contents of a repeating field shown on the FileMaker layout as "Serial #", 

which has been successfully converted with the RF Convert ScriptMaker script. If the RF convert 

script had not been run, then there would be vertical lines separating each repeating value. But 

since all of the repeating field data values have been placed into the first repeat occurrence, these 

vertical lines are not visible.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 96

FmPro Migrator sets the status of the Step 5 Convert Data (Repeating Fields) step to "In Progress" 

when you click the button to generate and put the script onto the ClipBoard. FmPro Migrator 

doesn't know when you have actually run the RF Convert script within ScriptMaker, so you should 

click the pop-up menu and set the status of this step to "Completed" once you have completed this 

task. Keeping the status selections updated can be helpful if you get interrupted while performing 

the migration, so that you will know which steps you have completed for each table to be migrated.
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Step 6
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Step 6 - Create Table (Repeating Fields)

Step 6 - Create Table (Repeating Fields)

Click the Step 6 Create Table (Repeating Fields) button to create the repeating fields table in the 

destination database.

FmPro Migrator will generate the table creation SQL code, connect to the destination database 

and create the table. Once the repeating fields table has been successfully created, the status 

menu under the Step 6 Create Table (Repeating Fields) button will be changed to "Completed".

Holding down the shift key while clicking the Step 6 Create Table (Repeating Fields) button drops 

and re-creates the table in the destination database. 

Warning: Dropping the table in the destination database causes the loss of all data within the 

table.
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Step 7



FmPro Migrator - FileMaker to Oracle Migration Procedure - 100

Step 7 - Transfer Data (Repeating Fields)

Step 7 - Transfer Data (Repeating Fields)

Click the Step 7 Transfer Data (Repeating Fields) button to transfer data from the source table in 

the FileMaker database to the newly created repeating fields table in the destination database. 

Once the data has been transferred successfully, the status menu below the Step 7 Transfer Data 

(Repeating Fields) button will change from "Not Started" to "Completed".

     Step 7 - Transfer Data (Repeating Fields) - Troubleshooting

All of the same troubleshooting steps apply to transferring repeating fields data as were mentioned 

within the Step 4 instructions. But one additional consideration involves reviewing the data 

transferred into the repeating fields.

Reviewing the data validates whether the each of the steps were processed correctly. For 

instance, if only 1 repeating value was transferred to the destination table, then this could mean 
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that the RF Convert script wasn't run or the contents of the source table fields weren't converted 

into Text prior to processing. If either of these problems occur, it is a simple matter to go back and 

re-do those processing steps, drop & re-create the table in the destination database then press the 

Step 7 button to transfer the data again. 
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Migrating Relationships
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Migrating Relationships

FmPro Migrator reads FileMaker Pro relationship info from DDR XML files exported by FileMaker 

Pro Developer/Advanced 7+. This relationship info is then used to create SQL code to re-create 

the relationships within the destination database. 

Migrating Relationships - Import DDR XML File

Within FmPro Migrator, (1) click on the Relationships tab, then (2) click on the Import Relationships 

button.

Note: Relationships will only be imported correctly if all of the base tables have already been 

created within the Tables tab.



FmPro Migrator - FileMaker to Oracle Migration Procedure - 104

Migrating Relationships - Import DDR XML File - Select File

(1) Select the exported DDR XML file, then (2) click the Open button. 

Don't select the Summary.xml file.

     Migrating Relationships - Generate Relationship SQL Code

Select one ore more relationships from the list, click on the Generate Relationship SQL button.

If the relationship cannot be generated from the FileMaker Pro relationship, error text will be 
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displayed within the Relationship SQL Code field. Otherwise, the generated SQL code will be 

displayed in the Relationship SQL Code field.

The most common reasons relationship code won't be generated are:

1) Having a missing primary key in the table.

2) The TO name specified in the relationship does not represent a base table. Relationship SQL 

code can only be generated for base tables, since these are the only tables which will get created 

in the destination database.

Any base tables which don't contain a primary key, will be listed in a error dialog when the 

Generate Relationship SQL button is clicked. This is just an informative dialog to let you know that 

relationships won't be generated for the tables which don't have a primary key. Relationship SQL 

code will still be generated for all of the remaining selected tables.

     Migrating Relationships - Create Relationships in Destination Database

Click the Transfer Relationships button to crete the selected relationships in the destination 

database.
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Image Export
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Image Export (Optional Step)

Images (and other types of data with FileMaker 7+) can be exported and saved as individual files 

on your local hard disk. In order to perform this type of export, you need to have at least one 

container field within the FileMaker Pro database table and one additional field which will contain 

the filename which will be given to each individual image.

Image Export

Click on the Image Export button to export images from the FileMaker Pro database table. This 

button will not be displayed if there are no container fields within the table.
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     Image Export - Field Selection

Select the name of the Container Field, Fieldname Field and Export Data Type from the Image 

Export window.

Note: The container field and fieldname field must not contain spaces, Unicode or high ASCII 

characters greater than 1 - 127, as the FileMaker ODBC driver does not support using these 

characters within SQL commands.
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     Image Export - Field Selection - Data Type

Select the data type from the Export Data Type menu. FileMaker 7+ supports storing 22 data types 

within container fields, as shown in this image. FileMaker 5/6 databases support exporting only the 

JPEG preview image stored with the container field data. Please see the FileMaker ODBC Driver 

PDF file for more details concerning these data types.
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     Image Export - Continue

Click the Continue button. FmPro Migrator will then prompt you for the output directory, and then 

will export a file for each record into the output directory you have selected.
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