Table Consolidation Layout
Troubleshooter



Table Consolidation Layout Troubleshooter

1 Overview

1.1 Overview - Table Consolidation Layout Troubleshooter

2 Usage

2.1 Using the Table Consolidation Layout Troubleshooter



Overview

Table Consolidation Layout Troubleshooter - 3



Overview - Table Consolidation Layout Troubleshooter

This document explains how to use the Table Consolidation Layout Troubleshooter utility to
resolve issues with layout creation after Pass#1 of the layout creation process.

When might you need to use this utility?
If the number of layouts created within the FileMaker database during Pass#1 doesn't match the
number of layouts listed within the Layouts tab of FmPro Migrator.

Despite it's name, this utility could be used for Access to FileMaker and Visual FoxPro conversion
projects in addition to its use for FileMaker Table Consolidation projects.

Documentation Revision 1
Table Consolidation Layout Troubleshooter 1.05
1/31/2020
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Usage
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Using the Table Consolidation Layout Troubleshooter

When to use the Table Consolidation Layout Troubleshooter utility?

FmPro Migrator automatically builds layouts within a FileMaker database during 3 different types
of conversion projects:

1) FileMaker Table Consolidation projects - in which multiple FileMaker database files are
consolidated/merged into one single new file.

2) Microsoft Access to FileMaker conversion projects - in which the Forms/Reports within an
Access database are converted into FileMaker layouts.

3) Visual FoxPro to FileMaker conversion projects - in which the Forms/Reports within a Visual
FoxPro project are converted into FileMaker layouts.

Since this process uses GUIl automation to perform the automated creation of layouts within the
FileMaker database, the possibility exists that one or more layouts could fail to get created for a
variety of reasons.

If this problem occurs, you will know that the number of layouts created within the FileMaker
database doesn't match the number of layouts listed within the layouts tab of the FmPro Migrator
Migration Process window.

Table Consolidation Note:

The number of layouts within the FileMaker database after Pass#1 should equal the number of
layouts listed in the layouts tab +1 - to account for the first layout named: Get TOs List within the
FileMaker template database:

# of Layouts in FmPro Migrator layouts tab
+1 - Get TOs List layout
= Total layouts in FileMaker database

Access & Visual FoxPro Note:

The number of layouts within the FileMaker database after Pass#1 should include the Get TOs List
layout plus the number of tables created, and the number of layouts listed in the FmPro Migrator
layouts tab:

# of Layouts in FmPro Migrator layouts tab:

+1 - Get TOs List layout

# of tables created (1 layout created for each table by default)
= Total layouts in FileMaker database
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GUI

O Table Consolidation Layout Troubleshooter

Troubleshooter 1.05

’ J ' www.FmProMigrator.com

3 1 Table Consolidation Layout

This utility exports the list of layouts from the
FileMaker XML file and the FmPro Migrator
MigrationProcess.db3 file in order to verify
that all Layouts were created.

FM18 XML Path: Browse
DB3 SQLite Path: Browse
Layouts: Read XML Layouts Layouts: Read SQLite Layouts

Save Output Files

The Table Consolidation Layout Troubleshooter uses 2 sources of information to obtain the lists of
layouts it produces:

1) The FileMaker XML file created by FileMaker 18 (or higher).
2) The MigrationProcess.db3 SQLite project file used by FmPro Migrator.

The outputfiles are two TAB delimited text files showing the name of each layout and its TO name.
Once the files have been created, a diff utility can be run to compare the files to each other.
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Selecting XML and MigrationProcess.db3 Files

O Table Consolidation Layout Troubleshooter

Troubleshooter 1.05

’ J ' www.FmProMigrator.com

3 1 Table Consolidation Layout

This utility exports the list of layouts from the
FileMaker XML file and the FmPro Migrator
MigrationProcess.db3 file in order to verify
that all Layouts were created.

FM18 XML Path: out_Troubleshooter/Asset_Management14_PHP02.xml Brows@
DB3 SQLite Path: lidation_Layout_Troubleshooter/MigrationProcess.db3 Brows@

Layouts: Read XML Layouts Layouts: Read SQLite Layouts

Save Output Files

1) First, export the database XML file using FileMaker Pro Advanced 18 (or higher), by selecting
the Tools -> Save a copy as XML... menu item.
Note: This tool uses the new FileMaker 18 XML file, not the older DDR XML file format.

Then click the Browse button to select this XML file for the FM18 XML Path field.

2) Click the Browse button to select the FmPro Migrator MigrationProcess.db3 SQLite file, the path
will get written into the DB3 SQLite Path field.
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Reading XML and MigrationProcess.db3 Files

' Troubleshooter 1.05

’ ' www.FmProMigrator.com

' J This utility exports the list of layouts from the
FileMaker XML file and the FmPro Migrator

MigrationProcess.db3 file in order to verify

that all Layouts were created.

O Table Consolidation Layout Troubleshooter
.‘ Table Consolidation Layout
l

FM18 XML Path: out_Troubleshooter/Asset_Management14_PHP0O2.xml| | Browse
DB3 SQLite Path: Dlidation_Layout_Troubleshooter/MigrationProcess.db3 = Browse

Layouts: Read XML Layouts @ Layouts: Read SQLite Layoul@
20 21

Assets v13 tbl_Assets Assets v13 tbl_Assets

Assets v8 Copy tbl_Assets Assets v8 Copy tbl_Assets

Bar Chart Gallery Members Bar Chart Gallery Member:
Companies 2  Companies 2 Companies Companies

controllers tbl_Assets Companies 2 Companies 2

Form tbl_Assets controllers tbl_Assets

Form - Depreciation tbl_Assets Form tbl_Assets

Form - Loaned To  tbl_Assets Form - Depreciation tbl_Asse'

Save Output Files

Click the (3) Read XML Layouts and (4) Read SQLite Layouts buttons.

The results will be displayed in the respective fields. In this example itis easy to see that the
number of layouts read from the FileMaker database XML file is 20 layouts, and the number of
layouts read from the FmPro Migrator MigrationProcess.db3 file is 21 layouts. So this means that
one layout is missing from the FileMaker database file.
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Creating Output Files

' Troubleshooter 1.05

’ ' www.FmProMigrator.com

' J This utility exports the list of layouts from the
FileMaker XML file and the FmPro Migrator

MigrationProcess.db3 file in order to verify

that all Layouts were created.

O Table Consolidation Layout Troubleshooter
.‘ Table Consolidation Layout
l

FM18 XML Path: out_Troubleshooter/Asset_Management14_PHP0O2.xml| | Browse
DB3 SQLite Path: Dlidation_Layout_Troubleshooter/MigrationProcess.db3 = Browse

Layouts: Read XML Layouts Layouts: Read SQLite Layouts
20 21

Assets v13 tbl_Assets Assets v13 tbl_Assets

Assets v8 Copy tbl_Assets Assets v8 Copy tbl_Assets

Bar Chart Gallery Members Bar Chart Gallery Member:
Companies 2  Companies 2 Companies Companies
controllers tbl_Assets Companies 2 Companies 2
Form tbl_Assets controllers tbl_Assets

Form - Depreciation tbl_Assets Form tbl_Assets

Form - Loaned To  tbl_Assets @ Form - Depreciation tbl_Asse'

Save Output Files

(5) Click the Save Output Files button, and the two text files will be written into the folder containing
the FileMaker XML file, and the folder will be opened automatically. The files can now be opened
and compared using your favorite text editor such as BBEdit (macOS) or UltraEdit (macOS &
Windows).

Each output file uses the format:
# Layouts - Line #1
<Layout Name> TAB <Table Occurrence Name> - for all of the remaining lines of text.
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BBEdit - Comparing Output Files

@® Find Differences

Left: ©-~ @

n
Right: ~/fmpro_migrator/Table_Consolidation_Troubleshooter/TestData/ B
S O - Asset_Management14_PHP02_FM18_XML_Layouts_List.txt ®

|~/fmpro_migrator/TabIe_ConsoIidation_TroubIeshooter/TestData/ o
Asset_Management14_PHP02_DB3_Layouts_List.txt R

Text Comparison * gelle[I@eZelploF:1g[e]y!

Case sensitive
Ignore curly quotes (" " ')
Ignore blank lines

Ignore spaces:

All
Leading
Trailing
Runs

®

Two files will be saved into the XML file directory, these files will be named after the name of the
XML file, such as the following:

Asset Management14_ PHP02_FM18 XML _Layouts List.txt
Asset Management14_PHP02_DB3_ Layouts_List.txt

On macOS, itis easy to use the free or paid versions of BBEdit to compare the two files.

Select the Search -> Find Differences... menu item.
Select the two files in the file selectors (1, 2), then click the Compare button.
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BBEdit - Search Results

€] ® Differences — Asset_Management14_PHP02_DB3_Layouts_List.txt vs. Asset_Management14_PHP02_FM18_XML_Layouts_List.txt
£+ ~/fmpro_migrator/.../TestData/Asset_Management14_PHP02_DB3_Layouts_List.... || £+ ~/fmpro_migrator/.../TestData/Asset_Management14_PHP02_FM18_XML_Layout... I
= =
1 pd 1 20

Assets v13 tbl_Assets
Assets v8 Copy tbl_Assets

2 2 Assets v13 tbl_Assets
3] B3 Assets v8 Copy tbl_Assets

4 Bar Chart Gallery Members 4 Bar Chart Gallery Members

5 Companies  Companies 5 Companies 2 Companies 2

6 Companies 2 Companies 2 6 controllers tbl_Assets
7 controllers tbl_Assets 7 Form tb1_Assets
8 8

Form tb1_Assets Form - Depreciation tbl_Assets

9 Form - Depreciation tbl_Assets 9 Form - Loaned To tb1_Assets
10 Form - Loaned To tbl_Assets 10 Information tbl_Assets
il Information tbl_Assets il List tb1l_Assets
12 List tb1l_Assets 12 Maint_Record tb1_Maintenance_Records
15 Maint_Record tb1_Maintenance_Records 13} Members Members
14 Members Members 14 Members_Test Members
il Members_Test Members il pages  tbl_Assets
16 pages  tbl_Assets 16 Pie Chart Gallery Members
17 Pie Chart Gallery Members 17 Popoverl tb1_Assets
18 Popoverl tb1_Assets 18 Popover2 tb1_Assets
19 Popover2 tb1_Assets 19 TabPanel_Test_FM16 tb1_Assets
20 TabPanel_Test_FM16 tbl_Assets 20 tbl_Value_List_Data_Items tbl_Value_List_Data_Items
21 tb1l_Value_List_Data_Items tbl_Value_List_Data_Items 244 views tb1l_Assets
22 views tbl_Assets
IERRGR o' Saved: 1/31/20, 4:05:42 PM B 318/ /22 LERTRGERT u' Saved: 1/31/20, 4:05:42 PM (3 493/../21

<apply & Apply >

Nonmatching Lines (File Asset_Management14_PHP02_DB3_Layouts_List.txt; Line 1; File Asset_Management14_PHP02_FM18_XML_Layouts_List.txt; Line 1)
Extra lines in Left before 5 in Right (File Asset_Management14_PHP02_DB3_Layouts_List.txt; Line 5; File Asset_Management14_PHP02_FM18_XML_Layouts_List.txt; Line 5)

Line #1 displays a difference due to the different count of layouts. But Line#5 is where the
difference exists for the list of layouts. The layout named Companies (using a TO with the same
name) shown on the left side as an extra layout which is the missing layout from the FileMaker
database XML export shown on the right side.
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UltraEdit - Comparing Output Files

@® Compare Files/Folders
Compare mode 2/3 way compare
o File o Two-way compare

File compare
First file to

/Users/dsimpson/fmpro_migrator/TabIe_ConsoIidation_TroubIeshooter/TestE

n

Second file to
/Users/dsimpson/fmpro_migrator/TabIe_ConsoIidation_TroubIeshooter/TestE @

Third file to

Compare options

Ignore case (text mode)
Compare highlighted text Ignore spaces (text mode)
RS CCPaISVRE Ignore blank lines (text mode)

O Text Ignore line terminators

? Cancel @ Compare

Note: You are using UltraCompare Lite. To get full file/folder/merge/compare

Download UltraCompare Professional here

Two files will be saved into the XML file directory, these files will be named after the name of the
XML file, such as the following:

Asset_Management14_PHP02_FM18_XML_Layouts_List.txt
Asset Management14_PHP02_DB3_Layouts_List.txt

On macOS or Windows, the UltraEdit text editor can be used to compare the two files.

Select the File -> Compare Files... menu item.
Select the two files in the file selectors (1, 2), then (3) click the Compare button.
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UltraEdit - Search Results

[ JOX ) UltraCompareX Lite
[ =5 q = n | 1] 2]
New Session Find Duplicates Print Preview Print Result ~All Differences Matching Vertical Layout Horizontal Layout Maximize First Pane Maximize Second Pane
Asset_Management14_PHP02_DB3_Layouts_List.txt | Asset_Management14_PHP02_FM18_XML_Layouts_List.txt

/Users/(...)/Asset_Management14_PHP02_DB3_Layouts_List.t ¥ = A /Users/(...)/Asset_Management14_PHP02_FM18_XML_Layout: ¥ & &

Output Window
1
i

B a3 E [}

Pair [1- 2] - 2 Block(s) diff 2 :1 Line(s) diff Different

Line #1 displays a difference due to the different count of layouts. But Line#5 is where the
difference exists for the list of layouts. The layout named Companies (using a TO with the same
name) shown on the left side as an extra layout which is the missing layout from the FileMaker
database XML export shown on the right side.
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Fixing Missing Layouts Procedure - Table Consolidation Projects

| BNON Migration Process

Tables  Relationships TOs  Value Lists CFs Layouts [ESICf9H] GUI
SR S Aw |

Assets v13 1790,2061
Assets v8 Copy 1792,2061
Bar Chart Gallery 1255,2190
Companies 355,127

Companies 2

Layout Migration:
[Used for Table
Consolidation, Access
to FileMaker Pro and
FileMaker Layout to

CAarmn

HTML’ Servoy' Visual —
FoxPro and Access

migration projects.]
Within FileMaker 7+ Portal Name
(layout mode), select
all objects on a layout
then select Copy from
the Edit menu. Click
the Add Layout button
on this screen to copy
the layout definition
from the clipboard
into FmPro Migrator.
Each layout can be
copied individually in
this manner, or all
layouts can be
imported in batch
mode (see info | v
below). Each layout is =
given a default name |
in the form: Layoutxx
where xx is an
incrementing number.
The currently
selected layout or
D

If there is only one missing layout, the easiest way to fix the issue is as follows:

1) Select the missing layout from the FmPro Migrator layouts tab, and click on the Copy Layout to
Clipboard button in FmPro Migrator. Create a new Layoutin the FileMaker database, setits TO
Name, delete the layout parts before pasting the layout from the clipboard. This layout will then go
into the last position within the list of layouts - normally causing a mismatch during Pass#2
processing.

2) Save a copy of the MigrationProcess.db3 file - into another folder.
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3) Delete the missing layout from the original MigrationProcess.db3 file.

4) Perform Pass#2 automated processing - this missing layout will get missed, but all of the other

layouts will have their contents replaced correctly.

5) Manually replace the contents of the missing layout by using the saved copy of the

MigrationProcess.db3 file.

Fixing Missing Layouts Procedure - Visual FoxPro and Access to FileMaker

Conversion Projects

Migration Process

TOs  Value Lists CFs Layouts

S

Companies

Relationships

Assets v13 1790,2061
Assets v8 Copy 1792,2061
Bar Chart Gallery 1255,2190
Companies

Companies 2

Layout Migration:
[Used for Table
Consolidation, Access
to FileMaker Pro and
FileMaker Layout to

CAarmn

HTML' Servoy, Visual D
FoxPro and Access

migration projects.]
Within FileMaker 7+ Portal Name
(layout mode), select
all objects on a layout
then select Copy from
the Edit menu. Click
the Add Layout button
on this screen to copy
the layout definition
from the clipboard
into FmPro Migrator.
Each layout can be

Scripts GUI

=R

copied individually in
this manner, or all

layouts can be

imported in batch
mode (see info

below). Each layout is
given a default name

in the form: Layoutxx
where xx is an
incrementing number.
The currently
selected layout or
S

If there is only one missing layout, the easiest way to fix the issue is as follows:
1) Select the missing layout from the FmPro Migrator layouts tab, and click on the Copy Layout to
Clipboard button in FmPro Migrator. Create a new Layoutin the FileMaker database, setits TO
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Name, delete the layout parts before pasting the layout from the clipboard. This layout will then go
into the last position within the list of layouts - which won't cause any problems.
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